Home > Unable To > Unable To Load Default Projecthelper Due To Java.lang.noclassdeffounderror

Unable To Load Default Projecthelper Due To Java.lang.noclassdeffounderror

Powered by: FUDforum 3.0.2.Copyright ©2001-2010 FUDforum Bulletin Board Software Back to the top Eclipse Foundation About us Contact Us Donate Governance Logo and Artwork Board of Directors Legal Privacy Policy Maybe you can add xercesImpl and the jaxp api at the end of the CLASSPATH when running ant? - -- .''`. : :' :rnaud `. `' `- -----BEGIN PGP SIGNATURE----- Version: here is my code, export CLASSPATH= export SOURCE_HOME=/root/CareBears1.2/CareBears export ANT_HOME=/root/apache-ant-1.6.2 export JAVA_HOME=/root/jdk1.3.1_15 export CLASSPATH=$CLASSPATH:$JAVA_HOME/lib/tools.jar export CLASSPATH=$CLASSPATH:$ANT_HOME/lib/ant.jar export CLASSPATH=$CLASSPATH:$ANT_HOME/lib/optional.jar export CLASSPATH=$CLASSPATH:$ANT_HOME/lib/ant-launcher.jar export CLASSPATH=$CLASSPATH:$SOURCE_HOME/lib/struts.jar export CLASSPATH=$CLASSPATH:$SOURCE_HOME/lib/servlet.jar export CLASSPATH=$CLASSPATH:$SOURCE_HOME/lib/mail.jar export CLASSPATH=$CLASSPATH:$SOURCE_HOME/lib/mysql-connector-java-3.0.16-ga-bin.jar export CLASSPATH=$CLASSPATH:$SOURCE_HOME/lib/activation.jar export Message #20 received at [email protected] (full text, mbox, reply): From: Arnaud Vandyck To: [email protected] Subject: Re: Bug#240245: NoClassDefFoundError: org/xml/sax/SAXException Date: Fri, 26 Mar 2004 16:09:27 +0100 -----BEGIN PGP SIGNED MESSAGE----- http://blacklex.com/unable-to/unable-to-load-default-projecthelper-due-to.html

Jan, Ant has a dependancy on xerces. Reply sent to Stefan Gybas : You have taken responsibility. Comment 1 Darin Swanson 2004-10-01 10:58:01 EDT Thanks for the bug report. April 30, 2004 at 6:03 am #206568 Reply arnorMember I think the problem is the new version of Eclipse 3.0M8 because in Eclipse 3.0M7 all work fine.

All other users should be unaffected by this change. Carol Enderlin drifter Ranch Hand Posts: 1364 posted 11 years ago Sounds like you're using ant 1.6.x. this made the installation terminate. So I have a work-around for the bug. > - -- > .''`. > : :' :rnaud > `. `' > `- > -----BEGIN PGP SIGNATURE----- > Version: GnuPG v1.2.4 (GNU/Linux)

  1. Please submit a ticket to Support and we will further assist you on this issue.
  2. Message #49 received at [email protected] (full text, mbox, reply): From: Stefan Gybas To: [email protected] Subject: Bug#240245: fixed in ant 1.6.1-2 Date: Sun, 06 Jun 2004 13:32:04 -0400 Source: ant Source-Version:
  3. Copy sent to Debian Java Maintainers .
  4. All rights reserved. 2221 Justin Road #119-340 Flower Mound, TX 75028 Insert/edit link Close Enter the destination URL URL Link Text Open link in a new tab Or link to existing
  5. Thanks!
  6. Thanks.

I am using the Sun JDK v1.3.1_10 installed to /usr/local/... Copy sent to Debian Java Maintainers . The problem occurs because of misconfiguration. I will now try to back out to an older >version of ant.

I will now try to back out to an older >>version of ant. > > Hey, that's teh same Arnaud is getting when building eclipse. Now I get these errors: Start installation on Generic Linux Platform (Linux) Installation Path: /usr/local/obm Configure Application Path: /usr/local/obm BUILD FAILED Unable to load default ProjectHelper due to java.lang.NoClassDefFoundError: org/xml/sax/SAXException Total Running Ant with JDK 1.4 doesn't help because then, Ant would use the javac of 1.4 which breaks my projects. http://indragni.com/blog/2008/07/11/unable-to-load-default-projecthelper-due-to-java-lang-noclassdeffounderror-orgxmlsaxsaxexception/ All Places > JBoss Tools > JBoss Tools Development > Discussions Please enter a title.

I removed it, so it will only use the files in the currently installed JRE. And then suddenly everything went south and we’re writing code… 2 days ago Twitter Facebook Google Plus Follow us on social media 01 Dec Webclipse CI 9 is out, and with I believe another workaround is to use Ant with JDK 1.4 but set the "source" and "target" attributes of your javac task appropriately to produce 1.3 compatible classfiles. Which is why the instructions in no longer available.

Search or use up and down arrow keys to select an item. learn this here now Maybe you can add xercesImpl and the jaxp api at the end of the CLASSPATH when running ant? - -- .''`. : :' :rnaud `. `' `- -----BEGIN PGP SIGNATURE----- Version: Please use version 9 or higher to avoid problems with your order(s). Ant to Maven Converter SAX Exception Ant in Eclipse classpath issues, please help Ant in Eclipse classpath issues, need help All times are in JavaRanch time: GMT-6 in summer, GMT-7 in

Maybe you can add xercesImpl and the jaxp api at > the end of the CLASSPATH when running ant? > I *do* have libxerces2-java installed (it was in the original posting, Check This Out Show 1 reply 1. Full text and rfc822 format available. Acknowledgement sent to James Damour <[email protected]>: Extra info received and forwarded to list.

April 29, 2004 at 5:42 am #206500 Reply arnorMember In my log when I start eclipse I found this: !SESSION apr 29, 2004 12:35:31.202 ------------------------------ java.version=1.4.2_03 java.vendor=Sun Microsystems Inc. Please type your message and try again. 1 Reply Latest reply on Nov 5, 2004 2:52 PM by Ron Dagostino Running packaging with JDK 1.3.x: Unable to load default Pro Ron Message #25 received at [email protected] (full text, mbox, reply): From: Arnaud Vandyck To: Jan Schulz <[email protected]> Cc: [email protected], James Damour <[email protected]> Subject: Re: Bug#240245: NoClassDefFoundError: org/xml/sax/SAXException Date: Fri, 26 Mar Source I have create a small ejb example but when I launch Xdoclet I don't got any feedback.

In the same VM, no Xerces as you get it for "free" from the Xerces plugin. tks in advace Lorenzo April 15, 2004 at 10:27 am #206029 Reply Riyad KallaMember Lorenzo, I think this thread will help: https://www.genuitec.com/forums/topic/error-when-running-xdoclet/&highlight=projecthelper April 15, 2004 at 11:32 am #206050 Reply arnorMember Full text and rfc822 format available.

Toggle useless messagesView this report as an mbox folder, status mbox, maintainer mbox Report forwarded to [email protected], Debian Java Maintainers : Bug#240245; Package ant.

Goto Forum: - NewcomersNewcomers- Language IDEsAJDTAndmoreC / C++ IDE (CDT)CheJava Development Tools (JDT)ObjectteamsOrionPHP Development Tools (PDT)Eclipse Web Tools Platform Project (WTP)ServerTools (WTP)- ModelingAMPAmalgamB3ATLBPEL DesignerCompareEcore ToolsEMFEMF "Technology" (Ecore Tools, EMFatic, etc) EpsiloneTriceExtended In what way are you *not* making that choice for the users? Request was from Bastian Blank <[email protected]> to [email protected] john collard wrote: > This is probably been asked several times before, and probably has a simple > solution... > > I get the following error building a project after setting

See the Ant manual for more information on configuring the javac task. Copy sent to Debian Java Maintainers . Seems to be the same one! ;-) But it's not the main problem when building eclipse on powerpc :'( - -- .''`. : :' :rnaud `. `' `- -----BEGIN PGP SIGNATURE----- have a peek here Thank you for reporting the bug, which will now be closed.

C:\Eclipse) When I run Ant the error is changed, now 🙂 output: Buildfile: C:\Program Files\eclipse_3.0_M8\workspace\videoComunity\build.xml init: [echo] classpath = C:\Program Files\eclipse_3.0_M8\workspace\videoComunity/build/ant compile_all: [flash] Flash compiling C:\Program Files\eclipse_3.0_M8\workspace\videoComunity\src flash\flash_detection.fla BUILD FAILED: Full text and rfc822 format available. When I try with ant I get: "BUILD FAILED: Unable to load default ProjectHelper". Bug75447 - BUILD FAILED: Unable to load default ProjectHelper due to java.lang.NoClassDefFoundError: org/xml/sax/SAXException Summary: BUILD FAILED: Unable to load default ProjectHelper due to java.lang.NoClassDe...

Your guess that Ant isn't adding an XML parser is correct but the reason is that I don't want to make the choice for the users: Some users might have an Full text and rfc822 format available. That fixed > the problem for me. > > john collard wrote: > > This is probably been asked several times before, and probably has a simple > > solution... > Acknowledgement sent to Jan Schulz <[email protected]>: Extra info received and forwarded to list.

Full text and rfc822 format available. Any Idea?